OpenRoads Designer CONNECT Edition SDK Help

CreateByStartPointStartRadiusEndRadiusLengthStartAngleTypeHand Method

Initializes a new instance of the Spiral class.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  Spiral CreateByStartPointStartRadiusEndRadiusLengthStartAngleTypeHand( DPoint3d startPoint,double startRadius,double endRadius,double lengthAlongSpiral,double startAngle, SpiralType type, Hand hand)

Parameters

SettingDescription
  DPoint3d Start point.
   Start radius.
   End radius.
   lengthAlongSpiral.
   Start direction.
  SpiralType Type.
  Hand hand.

Return Value

Spiral

See Also